Index du Forum

communauté marocaine des utilisateurs de backtrack
 
 Index du ForumFAQRechercherS’enregistrerConnexion
:: Fixer erreur d'update Metasploit ::

 
Poster un nouveau sujet   Répondre au sujet     Index du Forum -> Backtrack 5 -> Problèmes d'installation logiciel ou de configuration système
Sujet précédent :: Sujet suivant  
Auteur Message
Inf3rnus


Hors ligne

Inscrit le: 10 Mai 2012
Messages: 49

MessagePosté le: Mer 14 Nov - 07:59 (2012)    Sujet du message: Fixer erreur d'update Metasploit Répondre en citant




                                                                         Attention je LEECH




Depuis BackTrack 5 les utilisateurs n’arrêtent pas de se plaindre du message d’erreur affiché par le framework Metasploit à chaque lancement de msfupdate, eh ben souriez puisque je vais vous montrer comment fixer ce petit souci sur les distributions BackTrack 5 RX

     
Metasploit & BackTrack 5 R2

Le message d’erreur :







Code:

root@Inf3rnus:~# msfupdate[*] Attempting to update the Metasploit Framework...
[*]
svn: /opt/metasploit/common/lib/libssl.so.0.9.8: no version information available (required by /opt/metasploit/common/lib/libserf-0.so.0)
svn: /opt/metasploit/common/lib/libcrypto.so.0.9.8: no version information available (required by /opt/metasploit/common/lib/libserf-0.so.0)
svn: /opt/metasploit/common/lib/libssl.so.0.9.8: no version information available (required by /opt/metasploit/common/lib/libserf-0.so.0)
svn: /opt/metasploit/common/lib/libcrypto.so.0.9.8: no version information available (required by /opt/metasploit/common/lib/libserf-0.so.0)



La solution :

Code:

 cd /opt/metasploit/common/lib
 /opt/metasploit/common/lib# mv libcrypto.so.0.9.8 libcrypto.so.0.9.8-backup
 /opt/metasploit/common/lib# mv libssl.so.0.9.8 libssl.so.0.9.8-backup
 /opt/metasploit/common/lib# ln -s /usr/lib/libcrypto.so.0.9.8
 /opt/metasploit/common/lib# ln -s /usr/lib/libssl.so.0.9.8
 /opt/metasploit/common/lib# msfupdate






Metasploit & BackTrack 5 R1

Le message d'erreur :

Code:

root@Inf3rnus:~# msfupdate
[*]
[*] Attempting to update the Metasploit Framework...
[*]
svn: /opt/framework/lib/libssl.so.0.9.8: no version information available (required by /opt/framework/lib/libserf-0.so.0)
svn: /opt/framework/lib/libcrypto.so.0.9.8: no version information available (required by /opt/framework/lib/libserf-0.so.0)
svn: /opt/framework/lib/libssl.so.0.9.8: no version information available (required by /opt/framework/lib/libserf-0.so.0)
svn: /opt/framework/lib/libcrypto.so.0.9.8: no version information available (required by /opt/framework/lib/libserf-0.so.0)



La solution :

Code:

 cd /opt/framework/lib
 /opt/framework/lib# mv libcrypto.so.0.9.8 libcrypto.so.0.9.8-backup
 /opt/framework/lib# mv libssl.so.0.9.8 libssl.so.0.9.8-backup
 /opt/framework/lib# ln -s /usr/lib/libcrypto.so.0.9.8
 /opt/framework/lib# ln -s /usr/lib/libssl.so.0.9.8
 /opt/framework/lib# msfupdate



Pour plus d’informations sur la commande ln et la création des liens symboliques, consultez l’aide en utilisant le paramètre –help
_________________


Revenir en haut
Publicité






MessagePosté le: Mer 14 Nov - 07:59 (2012)    Sujet du message: Publicité

PublicitéSupprimer les publicités ?
Revenir en haut
Alien
Administrateur

Hors ligne

Inscrit le: 10 Mai 2012
Messages: 173

MessagePosté le: Mer 14 Nov - 20:13 (2012)    Sujet du message: Fixer erreur d'update Metasploit Répondre en citant

Merci

Revenir en haut
Contenu Sponsorisé






MessagePosté le: Aujourd’hui à 20:15 (2017)    Sujet du message: Fixer erreur d'update Metasploit

Revenir en haut
Montrer les messages depuis:   
Poster un nouveau sujet   Répondre au sujet     Index du Forum -> Backtrack 5 -> Problèmes d'installation logiciel ou de configuration système Toutes les heures sont au format GMT + 2 Heures
Page 1 sur 1

 
Sauter vers:  

Index | Panneau d’administration | forum gratuit | Forum gratuit d’entraide | Annuaire des forums gratuits | Signaler une violation | Conditions générales d'utilisation

© Alien 2012